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1 Summary 
This Implementation Guide describes how to integrate int_paypal, bm_paypal 

cartridges version 24.2.0 into Commerce Cloud reference application Store Front 

Reference Architecture (7.0.0 SFRA). 

Cartridges include: 

• PayPal Checkout from cart and payment pages 

• Apple Pay Checkout from product, cart and payment pages 

• Vault flow for Credit Card and PayPal 

• Review and post-process PayPal transactions in the Business Manager 

• Dynamic Smart Button styling management from the Business Manager 

• Configure custom site preferences in the Business Manager 

 

PayPal integration uses PayPal REST Order API for checkout and Payment API for 

transaction post processing in Business Manager. 

For more information, contact your PayPal support manager. 

2 Component Overview 

2.1 Supported Features 

2.1.1 Smart Payment Button 

PayPal Checkout with Smart Payment Buttons gives your buyers a simplified and secure 

checkout experience. PayPal intelligently presents the most relevant payment types to 

your shoppers, automatically, making it easier for them to complete their purchase using 

methods like Pay with Venmo, PayPal Credit, credit card payments. 

Button Demo 

NOTE: An authorized PayPal user has their own separate session and saves data separately 

for the domain from which the SDK is loaded (cookies, localStorage). The session is not 

cleared automatically when the user performs login/logout from their account. 

2.1.2 Billing Agreement and Reference Transactions (Deprecated)  

From version 24.2.0 Billing Agreement is deprecated and new Vault flow is introduced. 

2.1.3 Alternative Payment Methods 

Alternative payment methods allow customers across the globe to pay with their bank 

accounts, wallets, and local payment methods. Relevant alternative payment methods 

are automatically presented with Smart Payment Buttons. 

To learn more, see Alternative Payment Methods overview. 

Current solution uses unbranded experience. See an example here: 

Unbranded APM 

UPDATE: Now the integration supports alternative payment methods: 

https://developer.paypal.com/demo/checkout/#/pattern/client
https://developer.paypal.com/docs/checkout/apm/
https://developer.paypal.com/docs/checkout/apm/bancontact/
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- Apple Pay 

- Blik - for Polish locale. 

- Bancontact - for Belgian locale. 

- EPS - for Austrian locale. 

- iDEAL - for Dutch locale. 

- MyBank - for Italian locale. 

- P24 - for Polish locale. 

2.1.4 PayPal Credit Card Payment Processing 

Card Fields is a way to accept credit card payments securely using PayPal JavaScript 

SDK. PayPal’s payment gateway connects your storefront to any processor or bank that 

it supports. 

Important: PayPal Card Fields are applicable for the merchants who enabled advanced 

credit and debit card payments.  

Check: To confirm that Advanced Credit and Debit Card Payments are enabled for you, 

check your sandbox business account as follows: 

 1. Log into the PayPal Developer Dashboard, go to Apps & Credentials. In the REST 

API apps, select the name of your app. 

 2. Go to Features > Accept payments. 

 3. Select the Advanced Credit and Debit Card Payments checkbox and select Save 

Changes. 

Important: If the advanced credit and debit card payment status for the account is 

disabled, the merchant needs to ask for permission from PayPal. 

NOTE: If you as a merchant are making any changes in Credit/Debit cards settings 

(Merchant tools > Payment methods > Manage Credit/Debit Cards), to go smoothly with 

checkout, make sure the type of credit card matches one of the following below: 

• Visa 

• MasterCard 

• American Express 

• Diners Club* 

• Discover 

• JCB 

• UnionPay* 

• Maestro 

• Elo 

• Hiper 

• Hipercard 

https://developer.paypal.com/dashboard/


Copyright © 2024 PayPal Inc. All rights reserved. Component Overview | 6 

2.1.5 Limit of saved credit cards 

Allows setting the limit for saving credit cards to the buyer's wallet. The value of the 
property is equal to the number of credit cards which a logged-in user is allowed to save. 
By default, it is Unlimited. 

NOTE: If you decrease the value, already saved credit cards will not be deleted. 

2.1.6 Transactions post processing 

Orders paid with integration can be post-processed from a separate Business Manager 

module. Post-processing includes transaction capture, refund, and void. Captured orders 

can be connected to PayPal Tracking API. Also, you can create a new transaction. 

Check Business Manager chapter for more details. 

2.1.7 PayPal-provided Billing Address and Phone Number 

To retrieve a buyer's billing address and phone number from the PayPal Checkout flow, 

please contact your PayPal representative or PayPal Support to enable them. 

Important: Retrieving billing address and phone number should be enabled in 

merchant account before PayPal button will be enabled on a cart page. 

2.1.8 Connect with PayPal 

‘Connect with PayPal’ enables users to create an account for your website and log in using 

their PayPal credentials. 

NOTE: In case user logs in via Connect with PayPal for the first time they will also receive 

the credentials for login via a Single Authentication (Demandware standard login).  

Also, the user can access their pre-existing user's account (if it exists) via Connect with 

PayPal if the email of the pre-existing user account matches with the PayPal email.  

When a customer links or unlinks their PayPal account, they will receive an email 

notification. 

NOTE: we do not recommend using Login with PayPal functionality if you have custom 

options, namely the possibility of changing customers' emails. 

2.1.9 Webhook Support  

The purpose of the webhooks is to reflect changes which were done manually or 

automatically on PayPal console level. 

For now, only the following hooks are supported: Payment authorization voided, 

Payment capture refunded, and Payment capture completed, Vault payment-token 

created, Vault payment-token deleted, Customer dispute created, Customer dispute 

resolved, Customer dispute updated. 

2.1.10 PayPal Vault Flow 

Starting from 24.2.0 plugin version, Billing Agreement is deprecated, and new Vault 

flow is introduced.  
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To Enable Vault flow “Store PayPal account in Vault” Site Preference has to be set to 

“Enabled”. 

In order to migrate from Billing Agreement to Vault flow the 

‘PayPalMigrateBillingAgreementIDsToVaultTokens’ job should be run. This job converts 

saved PayPal accounts, namely Billing Agreement IDs to Vault tokens. If the job was not 

run and user open My Account page or login from Checkout page with saved BA 

accounts, they will be automatically converted to the Vault tokens in real time.  

NOTE: we strongly recommend to run ‘PayPalMigrateBillingAgreementIDsToVaultTokens' 

job before the migration. 

2.2 Privacy and Payment 

This integration requires access to the following customer data elements: Shipping 

Address, Order Details, Customer Profile. 

3 Implementation Guide 

3.1 Overview 

Two cartridges support this integration: 

1. int_paypal – Commerce Cloud storefront extension 

2. bm_paypal – Business Manager extension “Transactions”, “Disputes”, “Preference 

Configuration” and “Styles Configuration” 

NOTE: Starting from 23.4.0 release cartridge paypal_credit_financing_options is removed and 

no longer supported as deprecated. 

NOTE: Latest supported OCAPI (int_paypal_ocapi) is 24.1.0 and it is not maintained starting 

from 24.2.0 

3.2 Installation 

3.2.1 Import metadata archive 

Before installing the cartridge, make sure that you have a working sandbox with a site 

based on SFRA installed. 

1. Create metadata.zip from the metadata folder then upload and import it. To do so, go to 

Business Manager > Administration > Site Development > Site Import & Export. Upload the 

archive using ‘Local’ option in the Upload Archive section.  

2. After uploading choose metadata.zip in the list and click on import button. 
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Figure 3.2.1. metadata.zip archive import 

3.2.2 Add cartridge to cartridge path 

Add int_paypal into the cartridge path of a target site. To do so, go to Business Manager 

> Administration > Sites > Manage Sites > Your Target Site > Settings and insert int_paypal 

before your cartridges record, as shown in Figure 3.2.2.  

 

 

Figure 3.2.2.  Storefront cartridge path 

3.2.3 Adding API Credentials 

Services: 

• int_paypal.http.rest – is used for the main plugin logic (Smart Button, 

manipulations with transactions, etc.). 

To access credentials, go to Business Manager > Administration > Operations > Services > 

Credentials. 

You need to fill the next credentials with the identical data: 

• NAME: Paypal_Sandbox_Credentials 

SB URL: https://api.sandbox.paypal.com/ 

https://api.sandbox.paypal.com/
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Prod URL: https://api.paypal.com/ 

User: Client Id 

Pass: Secret 

For both credentials use Client Id as User and Secret as Password. Client Id and Secret 

can be obtained in the app details at the PayPal developer portal.  

For more details about REST apps and credentials please visit Get credentials page at the 

PayPal Developer Portal. 

UPDATE: Current integration supports only one credentials usage at a time. If you wish to 

use multiple credentials at one sandbox you should customize cartridge at 

PaypalRestService.js file. 

(Optional) For non-production activities we recommend enabling the communication log 

for the int_paypal.http.rest service. The communication log will log every request and 

response to the log files. To do this navigate to the Business Manager > Administration > 

Operations > Services and click on int_paypal.http.rest. Check Communication Log 

Enabled checkbox (Figure 3.2.3) 

PLEASE NOTE: By enabling the communication log, some details such as customer’s 

personal information including address, phone, and email will be logged in cleartext. 

This should only be used for debugging purposes. We recommend, if possible, to only 

use this in a sandbox; however, when used in production, ensure you are disabling / 

unchecking the communication log box immediately after you are done with your 

debugging. Further, some credentials will also be saved in cleartext. 

 

Figure 3.2.3. Service Example 

 

https://api.paypal.com/
https://api.paypal.com/
https://developer.paypal.com/docs/api/overview/#get-credentials
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3.2.4 PayPal Transaction and PayPal Styles Configuration Business Manager modules installation 

Add bm_paypal into the record of the Business Manager cartridge path. Go to Business 

Manager > Administration > Sites > Manage Sites > Manage the Business Manager Site 

> Settings as shown in Figure 3.2.4. 

  

Figure 3.2.4. Business Manager Cartridge Path 

Grant access to Business Manager modules: 

a. Go to Business Manager > Administration > Organization > Roles & Permissions and 

select the target role that needs to have access to PayPal Transaction 

management (e.g., the Administrator role) 

b. Select the Business Manager Modules tab in the drop-down list on top. You must 

select your target site as the active context. 

c. Scroll to the PayPal Plugin module. Grant access to it by selecting the checkbox 

(Transactions, Styles Configuration, Preference Configuration, Disputes) and 

clicking Update. 

 

NOTE: before granting assets to your Business Manager modules, the bm_paypal 

cartridge must be uploaded, and the correct cartridge path must be entered. 

Once you do this, every Business Manager user with that role will be able to manage 

PayPal Transactions by selecting Business Manager > Merchant Tools > PayPal Plugin 

> Transactions, change Smart Button styling under Business Manager > Merchant Tools 

> PayPal Plugin > Styles Configuration and change Custom site preferences under 

Business Manager > Merchant Tools > PayPal Plugin > Preference Configuration, 

manage PayPal Disputes by selecting Business Manager > Merchant Tools > PayPal 

Plugin > Disputes. 
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3.2.5 Custom cache configuration 

Custom cache required for fast and stable work on the integration. Navigate to Business 

Manager > Administration > Operations > Custom Caches and ensure that the "Enable 

Caching" checkbox is selected.  

There are 1 custom cache objects used by the integration: 

1. paypalRestOauthToken – OAUTH token for communication with PayPal REST API. Out 

of the box, the integration supports single site usage and the token retrieved from 

PayPal is cached. For multiple credentials usage we recommend removing the cache 

definition from caches.json file in the cartridge. 

Access tokens have a finite lifetime. In general, access tokens have a lifespan of 900 

seconds (15 minutes) or 32400 seconds (nine hours), depending on the associated 

scopes. You can find more information about the access token here: Access token 

‘paypalRestOauthToken’ cache definition has an additional value:  

‘expireAfterSecond’ – a cache finite lifetime with 900 default value. 

There are cases when ‘expireAfterSecond’ value can be higher than the access token 

lifetime and it can cause an error during PayPal REST API server usage. 

To avoid such errors, we recommend investigating the access token’s ‘expires_in’ 

value by following this link: Access token and setting an appropriate value into 

‘paypalRestOauthToken’ cache. To do this, follow the next steps: 

1. Go to ‘int_paypal/caches.json’ file in the project repository. 

2. Adjust ‘expireAfterSecond’ value with one you got during investigation 

 

 

Figure 3.2.5. Caches.json file 

UPDATE: Custom Cache could be disabled for developing or testing purposes. we do not 

recommend disabling it in production and staging ENVIRONMENTS to avoid performance 

issues and http calls quota violation.  

3.3 Configuration 

3.3.1 Updating Cartridge Custom Site Preferences 

Go to Business Manager > Merchant Tools > PayPal Plugin > Preference Configuration. You 

will see a list of available tabs (Figure 3.3.1) 

 

https://developer.paypal.com/reference/get-an-access-token/
https://developer.paypal.com/reference/get-an-access-token/
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   Figure 3.3.1 Preference Configuration 

 

The list of plugin site preferences:  

PayPal General tab 

1. Payment Model, which determines whether the funds are captured immediately 
(Sale) or later (Authorize). 

a. Authorization - authorize a payment by placing a hold on the customer’s card 

for the funds.' Capture funds immediately' site pref. should be set to 'no'. 

b. Sale (capture) - settling a purchase immediately, it means that authorization 

and capture occurs at the same time as the sale. Capture funds immediately' 

site pref. should be set to 'yes'. 

NOTE: Authorization is not supported by Local Payment Methods (LPM). 

2. Authorization and Capture webhook id, which is Webhook id of payment 

authorization voided, payment capture refunded, and payment capture completed 

events. 

3. List of enable funding methods, which allows setting up a list of additional enable 

funding methods for SDK URL creation (example: "paylater"). 

4. List of disable funding methods, which allows setting up a list of disable funding 

methods for SDK URL creation (example: "paylater" or/and "card"). 

5. Session Payments Enabled, which determines whether session payments should be 

enabled for guest or logged-in users or both or disabled. Does not work with 

Returning Customer Experience (Change Payment Method button). 

6. Enable Transaction Logs - enables logging of the requests and responses from PayPal 

while creating transaction. You can review these requests\responses in the 

Transaction Details. 

7. Merchant Name, which display the name of the business or individual receiving the 

payment in the Apple Pay and PayPal payment modal. 

PayPal Configuration tab 

1. PayPal Button Location, which allows setting up an additional PayPal button 

location on the website. 

2. PayPal Button messages location, which shows messaging directly with buttons to 

promote Pay Later offers and other PayPal value propositions. Messaging is currently 
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only supported for US merchants and US customers. Merchants must be eligible for 

Pay Later to display Pay Later offers with buttons. 

3. Store PayPal account in Vault, regulates buyers ability to manage their vault flow: 

- Enabled - buyers are allowed to save new payment methods and use previously 

saved ones. 

- Partially Disabled - buyers can use only previously saved payment methods. 

- Disabled - buyers cannot save new payment methods or use previously saved 
ones. 

4. PayPal Debit Credit Button Enable, which allows enabling PayPal Debit Credit 

Button on the storefront which will be displayed next to the PayPal button. Please 

note that the PayPal Debit Credit Button location will be the same as the location of 

the PayPal button. Pay attention that PayPal Debit Credit Button will not be 

rendered when PayPal Credit Card Payment Method is enabled. 

5. Pay Later Button Enable which allows enabling PayPal Pay Later Button on the 

storefront which will be rendered next to the PayPal button. Please note that PayPal 

Pay Later Button location will be the same as the location of the PayPal button. 

Depending on the vault mode and client-id one of the buttons will be rendered. 

6. Digital Goods enabled, the flow is designed for selling only Digital Goods, which do 

not require delivery to the shipping address. In case you enable this flow, the 

shipping options will be hidden on the storefront.  

NOTE: Digital Goods flow does not support Venmo payment method. 

7. PayPal Fraudnet Enabled, which allows collecting buyer's browser-based data and 

passing it to PayPal Risk Service to help reduce fraud. 

8. Connect with PayPal button enabled, which identifies whether the Connect with 

PayPal (CWPP) button is enabled on the Login and the Checkout pages. 

9. Connect with PayPal button url, the field for entering a URL which is used for 

Connect with PayPal feature. 

10. Connect with PayPal agent login, part of Connect with PayPal functionality that 

requires agent credentials to perform "Login On Behalf" action. 

11. Connect with PayPal agent password, part of Connect with PayPal functionality 

requires agent credentials to perform "Login On Behalf" action. 

12. Account Linking Security Layer enabled, which enables additional verification step 

(enter credentials from the pre-existing user account) during the account linking 

while your buyers use Connect with PayPal for the first time and the user account 

email matches with the PayPal primary account email. 

13. Automatic payment method adding enabled, which enables automatic adding of 

the PayPal account and address to the user account if this site pref. is set to 'yes' 

and Connect with PayPal button Is enabled. 

14. Account Linking Security Layer enabled, which enables additional security step 

where users should enter credentials for the existing account during first login via 

Connect with PayPal. 
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15. Simplified PayPal Dispute Page, which enables activating of the simplified UI of the 

PayPal Dispute page. 

NOTE: If Simplified PayPal Dispute Page is enabled, PayPal disputes will not be stored 

on the Demandware side. In addition, PayPal disputes will be retrieved and updated 

from PayPal in real-time by using dispute API. 

If Simplified PayPal Dispute Page is disabled, the full functionality of the Dispute page 

will be activated, i.e., search dispute section and dispute history will be shown.  In this 

case PayPal disputes will be stored in the custom object on the Demandware side and 

will be retrieved and updated via PayPal Dispute webhooks. 

PayPal Credit Card tab 

1. Store Credit Card in Vault, which regulates vault flow which allows saving credit 

cards for logged-in buyers:  

- Enabled - buyers are allowed to save new payment methods and use 

previously saved ones. 

- Partially Disabled - buyers can use only previously saved payment methods. 

- Disabled - buyers cannot save new payment methods or use previously saved 

ones. 

NOTE: If you disable this site preference and the logged-in user has a saved credit 

card in the wallet, then they will not be able to use it on the checkout. 

2. Store Credit Card in Vault via My Account. This site preference regulates vault 

options of saving Credit Cards only on My Account and becomes active only when 

"Store Credit Card in Vault" is Enabled. When set to "Yes" value, it allows User to 

save new Credit Cards from My Account. 

3. Verify Credit Card on My Account, which enables verification while saving credit 

cards on the My Account page.  

NOTE: 3DS verification can be requested automatically if it is required. 

4. Limit of saved credit cards, which allows you to set the maximum number of cards 

that logged-in user can save. 

NOTE: If you decrease the value, already saved credit cards will not be deleted. 

5. 3DS verification for Credit Card, which allows/disallows triggering 3D Secure flow 

on the Checkout page. 

6. Credit Card Expire Notification Configuration, which allows notifying and 

highlighting (show the respective label) logged-in buyers if their credit cards are 

expired or are going to expire. 

Apple Pay tab 

1. Apple Pay Button Location, which allows setting up an additional Apple Pay button 

location on the website. 

Pay Later Banners/Messaging tab 

1. Pay Later Messaging Location, which allows displaying banners/messaging on the 

PDP, Cart, Categories pages. 



Copyright © 2024 PayPal Inc. All rights reserved. Implementation Guide | 15 

2. Pay Later Cross-Border Messaging Enabled, which enables Cross-border messages 

for Pay Later. It means that the text for Pay Later messages can be displayed 

according to your website location. 

3.3.2 Job configuration for removal of outdated transaction 

To record a transaction created from Business Manager cartridge use custom object 

feature. After a year, a transaction becomes outdated and to remove it, use a job with a 

recurring interval which has been added to the site in the process of importing metadata. 

Job has site context and default site id is RefArch. If you have different site id, navigate 

to Business Manager > Administration > Operations > Jobs > 

RemoveOutdatedPayPalTransaction > Job Steps and click on RefArch mark near Scope 

and select new site to run. 

By default, this job will run every 2 months. If you do not create transaction from Business 

Manager or you want to change a job interval, navigate to Business Manager > 

Administration > Operations > Jobs > RemoveOutdatedPayPalTransaction > Schedule and 

History. Uncheck Enable checkbox if you want to disable the job or change an interval in 

the menu below. 

3.3.3 Static values configuration 

All configuration options are available in cartridge/config/sdkConfig.js file. You 

could change: 

1. Allowed currencies. By default, all currencies are allowed. The currency list is 

available under allowedCurrencies variable. More details Currency (currency section) 

2. Disable funds. By default, only alternative payment methods are disabled. More 

details Disable funding (disable-funding section) and Alternative Payment Methods  

3. Also, in  cartridge/config/paypalConstants.js file you can setup 

SOFT_DESCRIPTOR variable which will be processed as soft_descriptor field in 

transaction's purchaseUnit object. The soft descriptor is the dynamic text used to 

construct the statement that appears on a payer's card statement. More info on 

soft_descriptor can be found on  PayPal Order Documentation. 

3.3.4 PayPal Credit Card Configuration 

To enable Card Fields: 

1. Activate PayPal Credit Card payment method. Navigate to Business Manager > 

Merchant Tools > Ordering > Payment Methods and enable PayPal Credit Card payment 

method with payment processor PAYPAL 

2. Activate PayPal Debit Credit Button custom preference. Navigate to Business 

Manager > Merchant Tools > PayPal Plugin > Preference Configuration > PayPal and set 

value Yes for PayPal Debit Credit Button Enable 

NOTE: Card Fields are applicable for Sale and Authorize flows 

To add new credit type: 

https://developer.paypal.com/docs/checkout/reference/customize-sdk/#currency
https://developer.paypal.com/docs/checkout/reference/customize-sdk/#disable-funding
https://developer.paypal.com/docs/checkout/apm/
https://developer.paypal.com/docs/api/orders/v2/#definition-order
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1. Navigate to Business Manager > Merchant Tools > Ordering > Payment Methods 

and enable PayPal Credit Card payment method with payment processor Credit 

Card <PAYPAL_CREDIT> 

2. Go to Credit/Debit Cards tab and add new card with name and Type 

 

Figure 3.3.2 Adding new type of Credit Card. 

 

Figure 3.3.3 Adding new type of Credit Card. 

3.3.5 Limit of saved Credit Cards 

The Limit of Saved Credit Cards option allows to set a limit on the number of credit 

cards a customer can store in their wallet. The value of the property is equal to the 

number of credit cards that the logged in user can store. 
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Figure 3.3.4 Credit card limit preference 

By default, is Unlimited. Other options are also available: 

• 1 credit card 

• 2 credit cards 

• 3 credit cards 

• 4 credit cards 

• 5 credit cards 

• Unlimited 

NOTE: If you decrease the value, already saved credit cards will not be deleted. 

3.3.6 Limit of saved PayPal accounts 

The Limit of PayPal accounts option allows to set a limit on the number of PayPal 

accounts a customer can store in their wallet. The value of the property is equal to the 

number of PayPal accounts that the logged in user can store. 

 

Figure 3.3.5 PayPal Account limit preference 

By default, is 1 account. Other options are also available: 

• 1 account 

• 2 accounts 

• 3 accounts 

• Unlimited 

NOTE: If you decrease the value, already saved PayPal accounts will not be deleted. 

3.3.7 Alternative Payment Methods Configuration 

By default, all local? payment methods are disabled. To enable payment method, 

navigate to Business Manager > Merchant Tools > Ordering > Payment Methods  

Choose a payment method and set Enabled to Yes 

The following are the IDS of alternative payment methods that are supported by the 

integration: 

• bancontact 
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• eps 

• ideal 

• mybank 

• p24 

• blik 

• Apple Pay 

 

Figure 3.3.6. Payment Methods configuration 

UPDATE: Alternative Payment Methods, except for Apple Pay, are available only on the 

billing page and will appear only if Capture funds immediately preference is set to Sale 

Flow (Sale). 

3.3.8 Service Profile Configuration 

By default, integration does not have any service profile configuration. We recommend 

putting limitation and timeout values according to storefront traffic to prevent fraud or 

potential attack. You can read more about configuration values here. 

3.3.9 SendFailedTransactionEmail Job Configuration 

SendFailedTransactionEmail job checks transaction statuses for a specified period of 

time. In case it finds appropriate status, it will send an email to the specified address 

with the transaction statuses and amounts of these transactions. If there are no such 

transactions, then email will not be sent, and respective log will be recorded to the job 

log. The purpose of this job is to give merchants the ability to receive emails regarding 

the failed transaction in order to be aware of it and quickly make a certain decision. 

This job can accept the following job parameters: 

• Email – email address that is used for sending alerts. 

• DaysToRetrieve – the period for which you need to check transaction statuses 

(number of days). 

• StatusesToCheck – the statuses that will be considered to be checked, namely. For 

example: DENIED, DECLINED, FAILED. 

• AlertsInBM – activates alerts for failed transactions in Business Manager (default: 

true) 

 

Possible statuses list: 

https://documentation.b2c.commercecloud.salesforce.com/DOC2/topic/com.demandware.dochelp/content/b2c_commerce/topics/web_services/b2c_web_service_rate_limiter_circuit_breaker.html
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CREATED, PARTIALLY_CAPTURED, CAPTURED, VOIDED, PENDING, AUTHORIZED, 

COMPLETED, REFUNDED, PARTIALLY_REFUNDED, CANCELLED, EXPIRED, DENIED, 

DECLINED, FAILED 

NOTE: Statuses in StatusesToCheck parameter must be specified as it is shown in Figure 

3.3.7: in uppercase and with commas between the statuses. 

 

NOTE: Parameter settings are not shipped with the job. Only DaysToRetrieve parameter 

has default value '7' and AlertsInBM value is 'true'. Other parameters must be filled in 

manually using the Business Manager interface (as shown in Figure 3.3.7). 

 

Figure 3.3.7 sendFailedTransactionEmail parameters 

NOTE: In the case of a large number of orders, it is better to run the job more often to 

prevent a possible sandbox overload and performance decrease. 

NOTE: To see alert notifications in BM, you need to configure it. Go to Administration > 

Operations > Notification Settings. Find section PayPal Plugin > Transactions and 

choose where you want your alerts to appear (as shown in Figure 3.3.8). 
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Figure 3.3.8 Notification settings 

3.3.10 PayPalMigrateBillingAgreementIDsToVaultTokens Job Configuration 

PayPalMigrateBillingAgreementIDsToVaultTokens job convert saved PayPal accounts 

(Billing Agreement IDs) into Vault tokens, enabling logged-in buyers to use their saved 

PayPal accounts that were saved via the Billing Agreement flow. 

This job can accept the following job parameters: 

• sourceFolderPath: Target folder path related to IMPEX/src  

• sourceFileName: Source file name  

NOTE: If the merchant does not use the job to convert BA IDs into Vault tokens, the system 

will perform this conversion in "real-time" when a user successfully logs into their 

storefront account. 

NOTE: By default, value for saving folder is 

Impex/src/PayPalMigrateBillingAgreementIDsToVaultTokens. To change saving folder or 

name of the file parameters should be filled in manually using the Business Manager 

interface (as shown in Figure 3.3.9). 
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Figure 3.3.9 PayPalMigrateBillingAgreementIDsToVaultTokens parameters 

 

NOTE: To see alert notifications in BM, you need to configure it. Go to Administration > 

Operations > Notification Settings. Find section Operations > Jobs and choose where 

you want your alerts to appear (as shown in Figure 3.3.10). 

 

Figure 3.3.10 Notification settings 

 

3.3.11 Apple Pay Configurations  

To enable Apple Pay, perform the following steps:  

1) Complete sandbox onboarding steps: 

https://developer.paypal.com/docs/checkout/apm/apple-pay/#link-

setupyoursandboxaccounttoacceptapplepay 

2) Complete Go live steps for production:  

https://developer.paypal.com/docs/checkout/apm/apple-pay/#link-golive 

3) Enable Apple Pay Payment Method in BM. 

4) Configure Apple Pay Site Preference section to make Apple Pay button visible on 

pdp/pvp/cart/minicart pages. 

NOTE: Apple Pay is available only in Safari on the following platforms: 

-  iOS 12.1 and later 

-  macOS 10.14.1 and later 

3.3.12 Apple Pay Address fields validation 

From Apple Pay API version 3 and later Apple Pay JS API supports customized errors. It 

gives an ability to create validation rules for Billing and Shipping addresses in Apple Pay 

payment sheet. 

To read about the feature, please follow the link. 

The file for the setup validation is located at 

cartridges/int_paypal/cartridge/scripts/paypal/helpers/applePayAddressValidation.js  

This file provides basic US locale validation rules for Apple Pay address fields. Based on 

those rules, Apple Pay pop-up will throw a customized error:  

https://developer.paypal.com/docs/checkout/apm/apple-pay/#link-setupyoursandboxaccounttoacceptapplepay
https://developer.paypal.com/docs/checkout/apm/apple-pay/#link-setupyoursandboxaccounttoacceptapplepay
https://developer.paypal.com/docs/checkout/apm/apple-pay/#link-golive
https://developer.apple.com/documentation/apple_pay_on_the_web/applepayerror
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  Figure 3.3.11 Apple Pay pop-up window. 

 

These validation rules can be easily adjusted to meet the specific requirements simply 

by changing the appropriate regular expressions. It is also possible to create detailed 

errors by passing errorMessage for some specific field mismatch. For example:  

 

Figure 3.3.12 Apple Pay pop-up window Error message example. 

The validation result can be passed to completePayment or 

completeShippingContactSelection methods. Some contact fields can be passed only to 

completePayment method, some can be passed to both. For more detailed information, 

check Apple Pay documentation. 

3.3.13 L2 L3 Data Processing 

PayPal cartridge supports Level 2 and Level 3 data for Apple Pay, Credit Cards, PayPal, 

Venmo and LPM payments. 

In Business Manager navigate to Merchant Tools -> PayPal Plugin -> Preference 

Configuration -> General tab and set Level 2 and 3 Processing preferences to Yes. 

Some fields require additional configuration on code-level, and some are supported out 

of the box. 

 

Level 2 and Level 3 data mapping: 

L2 Fields 

Invoice ID: Passed 

https://developer.apple.com/documentation/apple_pay_on_the_web/applepayerrorcontactfield
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Tax Total: Passed 

L3 Fields 

Shipping Amount: Passed 

Discount Amount: Passed 

Ships From Postal Code: Not passed 

Shipping Address: Passed 

Line Items 

• Name: Passed 

• Description: Passed 

• Quantity: Passed 

• Unit Amount: Passed (This value cannot be negative or zero.) 

• SKU: Passed 

• URL: Passed 

• UPC: Passed 

• Unit of Measure: Not passed 

• Total Amount: Passed 

• Tax: Passed 

• Discount Amount: Passed 

• Commodity Code: Not passed 

 

3.4 Webhook support 

The purpose of the webhooks is to reflect changes which were done manually or 

automatically on PayPal console level. 

To configure webhook support, follow this PayPal guide.  

Steps for configuration: 

1. Go to the PayPal Developer and log in to the Dashboard with your account. 

2. Navigate to "Apps & Credentials" and select or create your REST API app. 

3. Scroll to the Webhooks and add new or select existing. 

4. Enter a URL to your site with an endpoint Paypal-WebHooks. 

The general rule for creation URL is:  

{your environment}. 

dx.commercecloud.salesforce.com/on/demandware.store/{your site}/{your 

local}/{controller} 

(Ex. https://xxxx-

https://developer.paypal.com/docs/api-basics/notifications/webhooks/rest/#to-use-the-dashboard-to-subscribe-to-events
https://developer.paypal.com/
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278.dx.commercecloud.salesforce.com/on/demandware.store/Sites-RefArch-

Site/en_US/Paypal-WebHooks). 

5. Only include events that are needed. 

6. Save and copy the Webhook ID. 

7.  Enter it to the Custom Site Preference with ID: PayPal Webhooks ID (PP_WH_ID) 

(which is located inside PayPal Plugins -> Preference Configuration > tab 

"General"). 

Figure 3.4.1 Example of created Webhook in PayPal Developer account 

NOTE: It does not have additional notifications regarding changes. 

NOTE: you may subscribe only to the events listed below. 

No Webhook name Description 

1 Payment authorization 

voided 

It is triggered when a payment has been voided. 

2 Payment capture refunded It is triggered when a merchant refunds a 

payment capture. 

3 Payment capture 

completed 

It is triggered when a payment capture is 

completed. 

4 Vault payment-token 

created 

It is triggered when a payment method is saved. 

5 Vault payment-token 

deleted 

It is triggered when a payment method is 

deleted from the customer's account. 

6 Customer dispute created It is triggered when a dispute is created 

7 Customer dispute resolved It is triggered when a customer dispute is 

resolved. 

8 Customer dispute updated It is triggered when a customer dispute is 

updated. 
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3.5 Plugin configuration exports (optional) 

A feature that allows merchants to download PayPal plugin configurations, such as PayPal 

custom preferences, PayPal services, enabled payment methods/processors and PayPal 

plugin logs. Additionally, it tests PayPal service connection. (Read more in chapter 4.8 

Plugin configuration exports (optional)) 

To configure the plugin exports feature: 

• first set up WebDAV and OCAPI access keys if they weren't set up before. To do so 

go to your profile and click on Manage Access Keys and generate access keys (double 

check that keys are enabled) 

• then go to Merchant tools > PayPal plugin > Preference configuration General Tab 

and paste WebDAV and OCAPI configurations in JSON format for the OCAPI 

Configuration and WebDAV Configuration preferences, e.g. 

• OCAPI Configuration preference (BRAINTREE_GENERAL_OCAPI_Config): 

{ 

    "clientId": "OCAPI client id", 

    "clientPassword": "OCAPI client password", 

    "apiVersion": "23.2", 

    "bmUserLogin": "SFRA Business manager login email", 

    "bmUserPassword": "Agent User Login and OCAPI access key" 

} 

• WebDAV Configuration preference (BRAINTREE_GENERAL_WebDAV_Config): 

{ 

    "host": "****.dx.commercecloud.salesforce.com", 

    "username": "SFRA Business manager login email", 

    "password": "WebDAV File Access and UX Studio access key" 

} 

• save and refresh the page. After that go to OCAPI configs, that are in 

Administration > Site development > Open Commerce API Settings, select Data 

type and add the following JSON (if JSON exists there already, just add the two new 

resource objects for the jobs): 

{ 

    "_v": "23.2", 

    "clients": [ 

        { 

            "client_id": "OCAPI client id", 

            "resources": [ 

                { 
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                    "methods": ["post"], 

                    "read_attributes": "(**)", 

                    "write_attributes": "(**)", 

                    "resource_id": "/jobs/*/executions" 

                }, 

                { 

                    "methods": ["get"], 

                    "read_attributes": "(**)", 

                    "write_attributes": "(**)", 

                    "resource_id": "/jobs/*/executions/*" 

                } 

            ] 

        } 

    ] 

} 

4 Operations and Maintenance 

4.1 Data Storage 

The int_paypal integration requires System Objects Extension to store payment-related 

information. 

OrderPaymentInstrument custom properties: 

• paypalOrderId – Result of a payment action (Auth, Order, Sale). 

• paypalVaultEmail – email address of vaulted PayPal Account 

• paypalBillingAddress – paypal billing address that is associated with payment 

instrument 

• paymentId – generally is used for collecting Funding source name (paypal, mybank, 

venmo…). 

• paypalLpmAccountHolderName – collects an account holder name provided by Local 

payment method’s response. 

• paypalPaymentStatus – collects a PayPal payment status. 

• paypalRequest – collects a PayPal request. 

• paypalResponse – collects a PayPal response. 

• paypalToken – collects a PayPal token needed for proper NVP PayPal Transactions. 

Profile custom properties: 

• isExternalProfile - Identifies whether the customer's profile is external (via Connect 

with PayPal). 

• isDisabledFeatureAPMA - Identifies whether the Automatic Payment Method Adding 

feature is disabled. 
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• flashMessages - contains messages to show. 

• isMergedAccount - Identifies whether user accounts are merged between PayPal and 

Single Auth. 

 

Order custom properties: 

• paypalPaymentMethod – Property to differentiate PayPal-related orders. 

4.2 Logs 

This integration introduces three new custom logs: 

1. PayPal Storefront Custom logs – starts with prefix custom-PayPal-blade2-2-appserver-

20150722.log. This Log file contains all errors-related information in the int_paypal 

cartridge. 

2. PayPal Business manager custom logs – starts with prefix custom- PayPal-BM-blade. 

This Log file contains all errors-related information in the bm_paypal cartridge. 

3. Service communication logs – starts with service-PayPalRest. These logs contain every 

request and response to the PayPal endpoint. To enable these logs, check Adding API 

Credentials Optional section.  

4.3 HTTP Service Availability 

You can track availability and downtime by service status in the Commerce Cloud Business 

Manager. Go to Administration > Operations > Service Status > int_paypal.http.rest.  

You can configure options for HTTP calls to REST API related to this PayPal integration via 

the Commerce Cloud Service Profile Interface. To do this, go to Administration > 

Operations > Services > Service Profiles -> PayPal_Default_Profile. You can set a timeout 

for all requests, enable the Circuit Breaker mechanism, and adjust the Rate Limit.  
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Figure 4.3.1. PayPal Service Profile Settings 

4.4 Testing 

You must obtain your own test account on the PayPal Developer Portal. If you can’t create 

your own PayPal Sandbox account, contact PayPal support. 

4.5 SFRA core templates overlay list 

The following templates from app_storefront_base cartridges are changed by int_paypal 

cart/cart.isml  

account/dashboardProfileCards.isml  

account/components/oauth.isml 

account/login.isml  

account/profileCard.isml 

checkout/billing/paymentOptions/paymentOptionsContent.isml 

checkout/billing/paymentOptions/paymentOptionsSummary.isml 

checkout/billing/paymentOptions/paymentOptionsTabs.isml 

checkout/billing/billingSummary.isml 

checkout/confirmation/confirmationDetails.isml 

checkout/cart/miniCart.isml 

checkout/customer/customerOAuthCard.isml 

checkout/checkout.isml 

https://developer.paypal.com/docs/api/overview/#get-credentials
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common/scripts.isml 

components/pageFooter.isml 

home/homePage.isml 

product/components/addToCartButtonExtension.isml 

product/components/addToCartGlobal.isml 

product/components/addToCartProduct.isml 

search/searchResult.isml 

Templates are up to date with SFRA 6.3.0 

4.6 Support 

To get help and support from PayPal: 

• PayPal Business support − Go to PayPal’s Contact Us and log in to your PayPal account. 

• Technical Support − Go to the Merchant Technical Support Help Center. 

4.7 Plugin service connection testing 

To test whether PayPal service (int_paypal.http.rest) has been configured successfully, 

go to Merchant Tools > PayPal plugin > Preference configuration and click the Test 

connection with PayPal button. 

 

 

Figure 4.7.1. Test connection with Braintree button 

If the service has been configured correctly, you will get a success message, otherwise 

an error will be shown. 

4.8 Plugin configuration exports (optional) 

To properly troubleshoot the PayPal plugin, you might need to collect plugin 

configurations and this feature allows you to do so in a few clicks and have needed data 

zipped and downloaded to your device. 

The downloads will include: 

1. List of PayPal custom preferences 

2. List of PayPal services 

3. Enabled payment methods and payment processors 

https://www.paypal.com/us/smarthelp/contact-us
https://www.paypal-techsupport.com/s/
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4. PayPal plugin logs 

5. General data like SFRA version, plugin version, PayPal Partner attribution id, 

instance type and compatibility mode 

Additionally, PayPal service connection will be tested to ensure that PayPal service is 

configured correctly. 

After the feature is set up (details in chapter 3.5 3.5Plugin configuration exports 

(optional)), click on Generate Plugin Configuration button in Merchant tools > PayPal 

plugin > Preference configuration. 

In the popup check the items you would like to download. If none is selected, only 

general data will be generated. 

The zip file will be downloaded into the location chosen in your browser downloads 

settings. 

Once everything is downloaded, you will see a success message, otherwise an error will 

be shown. 

NOTE: Downloaded files might contain sensitive data, thus before sending them to a 3rd 

party, look through the files. 

 

 

Figure 4.8.1. Generate Plugin Configuration button 

 

Figure 4.8.2. Generate Plugin Configuration popup 
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5 User Guide 

5.1 Business Manager modules 

5.1.1 PayPal Transactions 

This integration introduces a new Business Manager function, PayPal Transactions. See 

PayPal Transaction Business Manager module configuration for a detailed description of 

how to grant access to the PayPal Transactions page. 

The PayPal Transactions extension allows you to manage PayPal transactions assigned to 

Commerce Cloud Orders by the Commerce Cloud Business manager. PayPal Transactions 

module supports reauthorization (after 3 days), capture and partial capture, void, refund. 

The main PayPal Transactions page displays all orders in a site that were paid or partially 

paid by PayPal. You can access this page in the Ordering menu by selecting Business 

Manager > Merchant Tools > PayPal Plugin > Transactions. 

This page displays various information from the order record: 

 

Figure 5.1.1. PayPal Transactions Business Manager Main Page Interface 

The transaction statistics block shows the total number of all transactions sorted by 

payment status (as shown in Figure 5.1.2). 
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Figure 5.1.2. PayPal Transactions Business Manager Transactions statistics 

You can search Orders placed within PayPal order number (as shown in Figure 5.1.3) or 

by PayPal Transaction ID (as shown in Figure 5.1.4) or by PayPal Payment Status (as 

show in Figure 5.1.5). 

 

Figure 5.1.3. Search Orders with PayPal Transaction by Commerce Cloud Order Number 
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Figure 5.1.4. Search Orders with PayPal Transaction by Transaction ID 

 

Figure 5.1.5.  Search Orders with PayPal Transaction by Payment Status 

You can see Transaction Details from the PayPal Payment Transaction of the actual order 

by clicking Order Number or the Change link on the right. If an order has more than one 

related transaction, you will see a selection box with all the transactions that are related 

to the current order (as shown in Figure 5.1.6). 
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Figure 5.1.6. Transaction Details Popup 

 

Figure 5.1.7. PayPal Transactions Selected for Their Relationships to Commerce Cloud Order Transactions 

Depending on the transaction type and status, the order may have the following action 

buttons: 

• Capture (Figure 5.1.8) 
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• Void (Figure 5.1.8 and Figure 5.1.9) 

• Issue Refund (Figure 5.1.10) 

• Reauthorize (Figure 5.1.9)  

 

After click on a button pop-up with details will appear: 

• Void Form (Figure 5.1.11) 

• Capture Form (Figure 5.1.12) 

• Issue Refund Form (Figure 5.1.13) 

• Reauthorize Form (Figure 5.1.14) 

 

Figure 5.1.8. Authorized transaction payment actions  
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Figure 5.1.9. Authorized transaction payment actions (after 3 days) 

 

Figure 5.1.10. Captured transaction payment actions 
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Figure 5.1.11. Void Authorization Form 

 

Figure 5.1.12. Capture Form 
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Figure 5.1.13. Issue Refund Form 

 

Figure 5.1.14 Reauthorize Form 
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To view request and response log data for a particular transaction, use the Transaction 
Details window and the Transaction Logs section. This will help you analyze the information 

in more detail (Figure 5.1.15). 

 

Figure 5.1.15. Reauthorize Form 

If you need to create a new transaction - use the New Transaction button (see Figure 5.1.16) and 

log in to your Paypal account. 

 

Figure 5.1.16. "New Transaction" button  
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5.1.2 PayPal Styles Configuration 

Styles Configuration allows to choose styling of the Smart Button from the Business 

Manager. After installation, a new menu item will appear under PayPal Plugin in the 

Business Manager (Figure 5.1.17). 

 

 

Figure 5.1.17 PayPal Styles Configuration in the Business Manager 

If bm_paypal cartridge was installed properly you should see styling options for the 

PayPal Smart Button, Connect with PayPal, and Card Fields. Depends on buttons 

locations will be for Billing page or for Cart page. To read more about styling options 

visit Customize the PayPal Buttons. After configuration is done click Save Smart Button 

Configuration to update styling. 

 

Figure 5.1.18. Smart Button styling options 

 

https://developer.paypal.com/docs/checkout/integration-features/customize-button/
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Figure 5.1.19 PayPal Button Messaging configurations 

 

 

Figure 5.1.20. Connect with PayPal Button Configuration 

 

 

Figure 5.1.21. Card Fields Style Configuration 

 

 

Figure 5.1.22 Credit Banner configuration 
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5.1.3 PayPal Disputes 

This integration introduces a new Business Manager function, PayPal Disputes. See PayPal 

Transaction Business Manager module configuration for a detailed description of how to 

grant access to the PayPal Disputes page. 

The PayPal Disputes extension allows you to manage PayPal disputes assigned to 

Commerce Cloud Orders by the Commerce Cloud Business manager. 

The main PayPal Disputes page displays all opened disputes on a site. You can access this 

page by selecting Business Manager > Merchant Tools > PayPal Plugin > Disputes. (Figure 

5.1.23) 

This page displays various information from the dispute record: 

 

Figure 5.1.23 PayPal Disputes Business Manager Main Page Interface 

The disputes statistics block shows number and statutes of all disputes (as shown in 

Figure 5.1.24). 

 

Figure 5.1.24 PayPal Disputes Business Manager Dispute statistics 
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You can search Disputes placed within PayPal Dispute Status (as shown in Figure 5.1.25) 

or by PayPal Dispute Reason (as shown in Figure 5.1.26) or by PayPal Dispute ID (as show 

in Figure 5.1.27). 

 

Figure 5.1.25 Search Disputes by Dispute Status 

 

Figure 5.1.26 Search Disputes by Dispute Reason 
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Figure 5.1.27 Search Dispute by Dispute ID 

 

You can see Dispute Details from the PayPal Disputes by clicking View Details of the 

actual dispute (as shown in Figure 5.1.28) 

 

Figure 5.1.28 Dispute Details Popup 

You can see Transaction details from the Dispute popup by clicking Seller Transaction 

ID. (as shown in Figure 5.1.29) 
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Figure 5.1.29 Transaction details of Dispute 

 

To see Message History of Dispute press to Messages Related to the Dispute menu in 

Dispute details popup (as shown in Figure 5.1.30) 

 

Figure 5.1.30 Messages Related to the Dispute 
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You can go to PayPal Resolution Center to manage Dispute by clicking Dispute ID or the 

Resolution Center on the right (redirect to Resolution Center as shown in Figure 5.1.31). 

 

Figure 5.1.31 PayPal Resolution Center 

5.1.4 PayPal Tracking API 

If you sell tangible goods, you should send tracking information to PayPal as soon as you 

ship items to your customers. 

Providing tracking information and item-level details can also help you improve the 

customer experience and reduce your operational costs. You can achieve it using the 

following techniques: 

- Reduce dispute costs by allowing payers to dispute individual items instead of the 

entire order. 

- Quicker access to money in payment and dispute holds. Adding tracking to an order 

qualifies holds for the early release. 

- Real-time package tracking updates inside the PayPal app, which reduces the need 

for third-party apps to provide order tracking on PayPal orders. 

- Improved seller risk profiles built from shipping and order status, which helps lower 

reserve requirements. 

More information 

 

We have created a job for automatically searching for suitable orders and creating 

connections with Tracking API. Also, you can use the function itself. 

How to prepare order: 

1. Made full capture for the order transaction. (PayPal Payment Status should be 

COMPLETED)  

https://developer.paypal.com/docs/tracking/reference/carriers/
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2. Navigate to the captured order (Merchant Tools > Ordering > Orders > Order: [ID]). 

 

Figure 5.1.32 BM Order Page 

 

3. Open Shipment and enter the Tracking Number 

 

Figure 5.1.33 BM Shipment Page 

How to use Tracking API with job: 

NOTE: Job is searching for fully captured orders from the previous number of days.  

1. Go to Administration > Operations > Jobs and choose PaypalUseOrderTrackingApi 

job. 

2. Go to Job Steps to enter needed number of days (default 7) 
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Figure 5.1.34 BM Job Steps configuration 

3. Run the Job 

How to use Tracking API with function: 

Use function addTrackinAPI 

(bm_paypal/cartridge/scripts/paypal/paypalApi/bmPaypalApi.js). 

You need to pass an order to create tracking, but make sure that the order is captured. 

Important: by default, we pass OTHER as the shipment carrier. 

Add a specific shipment carrier: 

1. Navigate to the Merchant Tools > Ordering > Shipping Methods and press NEW or edit 

existed. 

2. Enter carrier name Into PayPal Carrier Name field (carrier must be supported by 

PayPal). 
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Figure 5.1.35 BM New Shipping Method configuration 

Important: PayPal Carrier Name must be taken from carriers list  

5.2 Storefront Functionality 

Integration has 3 types of checkouts with PayPal. All of them are available from the 

payment page or cart page. 

UPDATE: Checkout from cart requires customer data from PayPal. Review PayPal-provided 

Billing Address and Phone Number BEFORE ENABLING PAYPAL BUTTON ON A CART PAGE. 

1. One-time checkout. Available for both guest and registered user types. 

2. Checkout with vault creation. Available for registered user types if PayPal Vault Flow 

is enabled in Custom Preferences. 

3. Checkout using saved PayPal Account. Available for registered users that already 

passed checkout with PayPal at least once and saved it. 

5.2.1 Email, Phone, Shipping and Billing Address behavior 

When a customer proceeds to checkout using PayPal button on the Express Checkout page, 

their phone, email, shipping and billing address will be taken from customer’s PayPal 

account. During Express Checkout the shipping address validation will be performed to 

avoid having an order created with non-applicable shipping address (Figure 5.2.1). 

To checkout with a saved account, the default account values will be taken as shipping 

address and phone. 

If a customer leaves the email field empty during checkout from payment page, last used 

email from the session will automatically be set in a form or PayPal account email, in 

case the session value is empty. 

https://developer.paypal.com/docs/tracking/reference/carriers/
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Figure 5.2.1 Error message of failed shipping validation. 

5.2.2 Connect with PayPal 

Ability for a buyer to create a storefront account by clicking on just one button. 

This functionality is available on the following pages: Account Login, Page before 

Checkout (for guest buyers). 

Connect with PayPal provides customers with the option to access your website or app 

using their PayPal credentials or establish a connection between their PayPal account and 

your platform, facilitating the exchange of basic information. This solution utilizes only 

the primary email address obtained from PayPal and grants login access only for the 

validated email address. 

You can read more about this feature on this page. 

Enhanced functionality: 

1. Additional security layer - user who is logged in via PayPal for the first time and 
has a pre-existing SF user account with the same email as the primary email in 
My PayPal account, will be asked to put in the credentials from pre-existing SF 
user account before the account linking with PayPal. 

2. Email notifications: 

• In case a user logs in via Connect with PayPal for the first time, they will also 
receive an email notification for login via a Single Authentication (Demandware 
standard login). 

• A logged-in user who is linked via PayPal to their pre-existing SF user account, 
will be notified via email about account linking. 

https://developer.paypal.com/docs/log-in-with-paypal/
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• A logged-in user who is linked via PayPal to their pre-existing SF user account, 
will be notified via email about account unlinking. 

3. Automatic payment adding - adds account and address from PayPal to the user 
account. 

To use this feature, you have to go through these steps. During configuration on PayPal 

side, select all fields to successfully create an account on storefront: 

 

Figure 5.2.2 Connect with PayPal configurations 

After user clicks on the “Connect with PayPal” button and proceeds through PayPal 

authentication form successfully an account on storefront will be created with the data 

from PayPal buyer account. 

 

https://developer.paypal.com/docs/log-in-with-paypal/integrate/#enable-log-in-with-paypal
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Figure 5.2.3 Connect with PayPal button 

When deploying to production, do not forget to change Site Pref with ID: 

PP_CWPP_Button_Url  from https://www.sandbox.paypal.com/connect? To 

https://www.paypal.com/connect? (Check site pref description).  

Also, you should create and configure an agent user with specified permissions to use the 

full “Connect with PayPal” functionality: 

• go to “Administration > Organization > Roles & Permissions” and choose “New” 

• please fill in all the fields according to the example in the screenshot below 

(Figure 5.2.4) and click “Apply” 

Figure 5.2.4. New role creation  

 

https://www.sandbox.paypal.com/connect
https://www.paypal.com/connect
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• choose tab “Functional Permissions” (Administration > Organization > Roles > 

Agent Role - Functional Permissions). Select necessary site/sites to use your 

changes (Figure 5.2.5): 

 

Figure 5.2.5. Select Context 

   

• after “Apply” choose permissions as on screenshot below (Figure 5.2.6): 

 

Figure 5.2.6. Select Permissions 

• After that, you need to select an existing or create a new user and give him the 

“AgentRole” created in the previous steps (example Figure 5.2.7): 

 

Figure 5.2.7. User Role assigning 
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• click “Assign” on your user, choose “AgentRole” and click “Assign” one more 

time (Figure 5.2.8): 

 

Figure 5.2.8. User Role selecting 

• after that fill all necessary Preference Configuration settings in Merchant Tools 

> PayPal Plugin > Preference Configuration > tab PayPal (Figure 5.2.9) enable 

feature, enter URL for feature and enter your User Login and Password: 

PLEASE NOTE: In case an "Agent User Login and OCAPI" access key was created, 

you should fill the "PP_CWPP_Agent_Password" preference using this key instead 

of a password, as it takes precedence over the base password approach. 

 

 

 

Figure 5.2.9. Custom Preferences filling 

 

Recommendations which should be followed before moving to production: 

1. Go to PayPal Sandbox configuration:  

• Enter your credentials for accessing PayPal Dev Console.  

• Go to the My Apps & Credentials. 

• Select your application. 

• Go to SANDBOX APP SETTINGS. 
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• Click Advanced on (bellow Log in with PayPal checkbox). 

• Unselect the ‘Enable customers who have not yet confirmed their email 
with PayPal to log in to your app’ checkbox. 

2. Ensure that you have configured email confirmation for user account registration 
and MFA. 

5.2.3 PayPal Digital Goods(Previous Pay Now). 

PayPal ‘Digital Goods’ button helps to simplify buyer’s checkout by shortening the user 

journey in the PayPal checkout window.  

‘Digital Goods’ is applicable to PayPal, Apple Pay, Alternative payment methods and 

PayPal Credit Card (Card Fields). 

This functionality is available on the following pages: PDP (Product), Mini Cart, Cart, 

Billing pages (for both guests and logged-in users who have their PayPal accounts.). 

NOTE: Digital Goods for Alternative payment methods and PayPal Credit Card (Card 

Fields) is available only on the Billing page. 

You can find more details by following the link:  PayPal Checkout 

 

To apply this feature, go to Merchant Tools > PayPal Plugin > Preference 

Configuration > tab General, tab PayPal, tab Credit Card and make sure the following 

site preferences are set to: 

• Payment Model (PP_Payment_Model) – Sale Flow (Sale) 

 

Figure 5.2.10. Payment Model site preference 

 

• Digital Goods enabled (PP_Digital_Goods_Flow_Enabled) – Yes (By default is set 

to No) 

 

 

Figure 5.2.11. Digital Goods enabled site preference 

 

• Store Credit Card in Vault (PP_Store_CC_To_Vault) – No (By default is set to No) 

 

https://developer.paypal.com/docs/checkout/
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Figure 5.2.12 Store Credit Card in Vault site preference 

 

When everything is set correctly and the ‘Digital Goods’ is enabled, the PayPal button 

will activate the following flow: 

1. PayPal ‘Digital Goods’ button is rendered, and the following alert message is 

rendered on the Cart page: ‘Shipping address is not required for Digital Goods 

and provided address by PayPal will be ignored.’. 

 

 

Figure 5.2.13. PayPal button on the Cart page during 'Digital Goods' flow 

The following alert message is rendered on the Billing page: ‘Shipping address is not 

required for Digital Goods flow’: 

 

 

Figure 5.2.14. PayPal button on the Billing page during Digital Goods flow 
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2. When buyer clicks on the 'Buy Now' button, the following window is shown: 

 

 

Figure 5.2.15. PayPal window during 'Digital Goods' flow 

NOTE: Shipping section does not appear since ‘Digital Goods’ is used only for Digital 

Goods that do not require shipping. 

3. After clicking on the ‘Complete Purchase’ button, the buyer will be redirected to 

the Order review page. The following alert message is rendered on the Order 

confirmation page: ‘Shipping address is not required and Shipping Method is not 

required’. 

 



Copyright © 2024 PayPal Inc. All rights reserved. User Guide | 58 

 

Figure 5.2.16. The Order confirmation page view after ‘Digital Goods’ flow is successfully processed 

In case when ‘Digital Goods’ flow is disabled due site preferences, the general PayPal 

button flow is applied. 

5.2.4 One-time checkout (non-vault flow) 

One-time checkout is available from payment page (Figure 5.2.19) and from cart page 

(Figure 5.2.17), if custom preferences value of Show PayPal button on the cart page is 

set to 'Yes'.  

After clicking on the available payment method from Smart Payment Button the customer 

proceeds through checkout on PayPal side (Figure 5.2.18) and returns to the storefront to 

the order review page (Figure 5.2.21).  
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Figure 5.2.17 Checkout from the cart page using Smart Button 

 

 

Figure 5.2.18. Basic checkout pop-up example 
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Figure 5.2.19. Checkout from the payment page using Smart Button 

 

 

Figure 5.2.20. Checkout from the payment page with already chosen account 
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Figure 5.2.21. Order review page 

5.2.5 Checkout with PayPal Vault Flow 

For registered user, the integration provides an ability to save PayPal Account to vault as 

payment method in a storefront. This allows them to proceed through checkout with 

PayPal faster next time. 

To enable vault flow in Business Manager, navigate to Merchant Tools -> PayPal Plugin > 

Preference Configuration > tab PayPal and set Store PayPal account in Vault preference 

value to Enabled 

Visually checkout with vault is similar to Basic checkout (non-vault flow) with 2 major 

differences: 

1) On the payment page the registered customer has an additional checkbox Save PayPal 

account (Figure 5.2.22). 

2) On PayPal side after login the customer will see Save and Continue instead of Save 

and no shipping address option (Figure 5.2.23). Check Email, Phone, Shipping and 

Billing Address behavior for more details. 
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If the registered customer had Save PayPal account checkbox checked after order was 

placed successfully, they can review saved PayPal account in My Account section. (Figure 

5.2.24). 

 

 

Figure 5.2.22. Smart Button for registered user with vault enabled on the payment page 

 

 

Figure 5.2.23.  Saving to vault on the PayPal page 
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Figure 5.2.24. My Account section with saved PayPal account 

5.2.6 Checkout using saved PayPal Account 

After the registered customer saves PayPal account to vault (Figure 5.2.24), they can pay 

for an order using vaulted payment method and proceed through the checkout without 

Smart Button loading. 

Review Email, Phone, Shipping and Billing Address behavior for more information about 

addresses behavior for saved account. 

 

 

 

Figure 5.2.25. Saved PayPal account on the payment page 
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5.2.7 Checkout with multiple saved PayPal accounts 

User can save new PayPal accounts till they reach the limit. Site preference “Limit of 

saved PayPal accounts” regulates the number of accounts that can be saved. Default 

value is “1”. 

Customer can add new account from billing page. In a dropdown with saved account 

customer must choose New PayPal account option and load Smart Button (Figure 5.2.26).  

After an order is placed, the customer can observe the new account in My Account section 

(Figure 5.2.27) and in the dropdown on the payment page (Figure 5.2.28).  

Logged-in users can save a PayPal account via the Checkout page (Payment step) to the 

wallet only once. It means in case the user doesn't have a saved PayPal account in the 

buyer's wallet/PayPal Vault, then the Save my PayPal account to the wallet checkbox is 

shown. If the user has a saved PayPal account in his buyer's wallet/PayPal vault then the 

Checkbox is hidden on the UI level and as a result, the buyer cannot save a new PayPal 

account via the Checkout. 

 

 

Figure 5.2.26. New PayPal account option on payment page 
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Figure 5.2.27. Multiple saved accounts in My Account section 

 

 

Figure 5.2.28. Multiple account view on payment page 

5.2.8 Alternative Payment Methods 

Alternative payment methods allow customers across the globe to pay with their bank 

accounts, wallets, and other local payment methods. The Relevant alternative payment 

method is automatically presented in a separate tab by using unbranded flow. See an 

example here: Unbranded APM 

https://developer.paypal.com/docs/checkout/apm/bancontact/
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For example, a customer in the Netherlands might want to pay using iDEAL, which is used 

by more than half of consumers in the Netherlands for online purchases, whereas a 

customer in Belgium on the same website might want to pay using Bancontact, a popular 

payment method there.  

Alternative Payment Methods are available on the billing page only. Shipping address and 

phone number are always provided by the customer. Email will be pulled from the billing 

page. 

The transaction will be completed only when the customer returns to the storefront. If a 

transaction was not confirmed or the customer did not finish checkout on the PayPal side, 

the customer’s basket still will be available. 

Important: after the customer confirms the transaction and returns to the storefront, 

the order is placed immediately, skipping the Order Review page. 

UPDATE: Alternative Payment Methods appearances based on storefront locale, not on 

customer’s locale. 

 

 

Figure 5.2.29.  Alternative Payment Methods appearances on the billing page 
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Figure 5.2.30.  Alternative Payment Method transaction confirmation 

 

5.2.9 Venmo Payment Method 

It appears on the ‘Product’, ‘Cart’, ‘Mini-Cart’, ‘Billing’ pages in case if ‘Venmo’ 

payment method is available. 

 

 

Figure 5.2.31.  Venmo payment method on the Billing page 
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Figure 5.2.32. Venmo payment method on the express checkout page (Product, Cart, Mini-cart) 

5.2.10 Manage Vault flow from My Account 

If Vault flow was enabled in the Custom Preferences, the customer can save PayPal 

Account as payment method for faster checkout or remove saved account from My 

Account section at a storefront (Figure 5.2.33).  

 

 

 

 

Figure 5.2.33. PayPal section in My Account 

After customer clicks Add New button, PayPal Smart Button appears and customer must 

click on it to run through Vault flow. Once customer approves saving PayPal Account, 

the page will be reloaded and a new PayPal account email will appear under PayPal 

section (Figure 5.2.34). 
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Customer can delete PayPal account on remove button or from PayPal side. If customer 

deletes PayPal vault form PayPal it will be automatically removed from My Account. 

 

 

Figure 5.2.34. Saved PayPal Account view in My Account 

5.2.11 Credit Card functionality on the Billing page 

Card fields are rendered instead of the default credit card fields on the billing page. 

Available options:  

• Pay with Credit Card 

 

Figure 5.2.35. Card Fields form 

• Save Credit Card 

To configure Save Credit Card go to Business Manager > Merchant Tools > PayPal Plugin > 

Preference Configuration > Credit Card and enable Store Credit Card in Vault 

(PP_Store_CC_To_Vault) 
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NOTE: Save Credit Card on the Billing page via Card Fields works using separate from the 

My Account page API 

 

• Pay with saved Credit Card 

 

Figure 5.2.36. List of saved Credit Cards 

NOTE: Save Credit Card and Pay with saved Credit Card applicable only for registered 

users. 

5.2.12 Credit Card functionality on the My Account page 

Credit Card on the My Account page gives customers the ability to manage credit card 

payment methods. 

Available options:  

• Save Credit Card 

NOTE: Save Credit Card on the My Account works using separate from card fields API  

NOTE: Enable Store Credit Card in Vault and Store Credit Card in Vault via My Account 

Custom Preferences to be able to save Credit Card via Card Fields on the Account Page 

NOTE: The number of stored credit cards may be limited by preference 

Business Manager > Merchant Tools > PayPal Plugin > Preference Configuration > Credit 

Card 

 

Figure 5.2.37. Credit Card section If vaulting Is not active 

• Delete Credit Card 

• Make default Credit Card 

 

https://developer.paypal.com/docs/checkout/save-payment-methods/during-purchase/js-sdk/cards/
https://developer.paypal.com/docs/checkout/save-payment-methods/purchase-later/payment-tokens-api/cards/
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Figure 5.2.38. Credit Card section 

 

Figure 5.2.39 Limited Credit Cards 
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Figure 5.2.40. Credit Card form 

 

5.2.13 Credit Card 3dSecure Fallback  

The system will decide if the activation of the 3DSecure flow is mandatory for the 

customer's credit card after verification. Verification is based on requirements which 

include Strong Customer Authentication (SCA) - an authentication process that validates 

the identity of the user or a payment service or a payment transaction. The additional 

context, or payment indicator, ensures that buyer authentication and card on file, among 

other factors, are appropriately handled. In our plugin we cover some scenarios based on 

'payment_initiator', 'payment_type' and 'usage' indicators. Failure to pass these 

payment indicators might result in rejected transactions. You can find more info on SCA 

and payment indicator on  PayPal Developer portal. 

Applicable to the following payment methods - saved and non-saved credit cards. 

To enable go to: Merchant Tools > PayPal Plugin > Preference Configuration > Credit Card 

tab and set 3DS verification for Credit Card. 

NOTE: Even though SCA payment indicators are passed for saved credit cards, the 

3DSecure verification popup will not be triggered on the Billing page. It shows up on My 

https://developer.paypal.com/docs/multiparty/checkout/advanced/customize/sca-payment-indicators/
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Account page when credit card is being saved, if Store Credit Card in Vault via My 

Account site preference is enabled. 

 

5.2.14 Credit Card Expire Notification 

This functionality will notify the customer about the expiration of a credit card which is 

already expiring or has already expired. By default, this functionality is disabled. Other 

options are also available: 

• Notify when expired only - will notify and highlight only if CC is expired 

• Notify 1 month before expiration - will notify and highlight CC's which are going to 

expire in 1 month 

• Notify 2 months before expiration - will notify and highlight CC's which are going 

to expire in 2 months 

• Notify 3 months before expiration - will notify and highlight CC's which are going 

to expire in 3 months 

To enable go to: Merchant Tools > PayPal Plugin > Preference Configuration > Credit 

Card tab and set PP_Credit_Card_Expire_Notification 

An example of notifications can be seen below (Account, Checkout page): 

 

Figure 5.2.41 Credit Card Expire Notification (Account page) 
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Figure 5.2.42 Credit Card Expire Notification (Checkout page) 

5.2.15 Credit Messaging 

Credit Messaging is present on: 

• Category page - Figure 5.2.43 

• Product detail page - Figure 5.2.44 and Figure 5.2.45 

• Cart page - Figure 5.2.46 

The visibility of each message can be changed in Custom Preferences at the Business 

Manager. Check Updating Cartridge Custom Site Preferences for details. 

Credit option for cart and category page is calculated based on current cart total. If the 

cart total is lower than 150, credit messages will notify customer about it. (Figure 5.2.45)  

For PDP page the product price will be used as a value for credit options. For product 

sets the message appears for each option and for set total.  

 

 

Figure 5.2.43 Credit message on category page 
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Figure 5.2.44. Credit message on PDP page 

 

Figure 5.2.45.Credit message for product with small price 
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Figure 5.2.46. Credit message on cart page 

 

Figure 5.2.47.Credit message pop-up 

You can change the location of the credit message by moving templates according to 

storefront design.  

PDP message is represented by two templates: bundleDetailCreditMessage.isml 

and productDetailCreditMessage.isml which are located at 

cartridges/paypal_credit_messaging/cartridge/templates/default/pro

duct/components/socialIcons.isml template. 
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Cart message Is represented by cartCreditMessage.isml which is located at 

cartridges/paypal_credit_messaging/cartridge/templates/default/car

t/cart.isml  

Category message is represented by categoryCreditMessage.isml which is located 

at 

cartridges/paypal_credit_messaging/cartridge/templates/default/sea

rch/searchResultsNoDecorator.isml 

5.2.16 Button Messages 

Button Messages is present on: 

• Product view page - Figure 5.2.48 

• Product detail page - Figure 5.2.50 

• Mini Cart page - Figure 5.2.51 

• Cart page - Figure 5.2.52Figure 5.2.52Figure 5.2.46 

• Billing page - Figure 5.2.53 

The visibility of each message can be changed in Custom Preferences at the Business 

Manager. Check Updating Cartridge Custom Site Preferences for details. 

Credit option for cart and category page is calculated based on current cart total. If the 

cart total is lower than 150, credit messages will notify customer about it. (Figure 5.2.49) 

For PDP and PVP page the product price will be used as a value for credit options. For 

product sets the message appears for each option and for set total. 

 

Figure 5.2.48 Button Message on Product view page 
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Figure 5.2.49 Button message for product with small price 

 

 

Figure 5.2.50 Button Message on Product description page 
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Figure 5.2.51 Button Message on Mini cart page 

 

Figure 5.2.52 Button Message on Cart page 
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Figure 5.2.53 Button Message on Billing page 

 

 

6 Locales and addresses 

6.1 General info 

Out of the box PayPal is using built-in SFRA locations for checkout from billing or cart 

page. 

Checkout is available only with one locale, multi shipping and multi locales are not 

supported. 

7 Multi-site and multi-credential support 

7.1 General info 

PayPal cartridges do not come with multi-site or multi-credential support out of the box. 

On the service level built-in logic will use only int_paypal.http.rest  service and credentials  

attached to the service to communicate PayPal REST API. 
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8 Gift Certificate Support 

8.1 General info 

PayPal cartridges do not provide the ability to add a gift certificate to a basket or redeem 

gift certificates during checkout. 

The Customer can pay for a gift certificate using PayPal. If a gift certificate is the only 

item in the basket, the shipping address will not be requested from a customer and the 

billing address will be set as the shipping address. 

If the customer adds a gift certificate as a payment option and it partially covers the 

order total, the customer can pay the rest using PayPal. In this case the gift certificate 

amount will be treated as a discount and subtracted from the order total. 

8.2 Technical info 

Integration supports only gift certificates from B2C Commerce API. Gift certificate as 

product should be present as GiftCertificateLineItem in a basket. Gift Certificate 

as payment method should be applied as OrderPaymentInstrument using 

createGiftCertificateLineItem function. 

For more information, contact your PayPal support manager. 

9 Version and SFRA Support Info 

9.1 JavaScript Files and Cartridge Version Location 

The JavaScript files to be added to your page are located at: 

cartridges/int_paypal/cartridge/templates/default/home/homePage.is

ml 

cartridges/int_paypal/cartridge/templates/default/account/dashboar

dProfileCards.isml 

cartridges/int_paypal/cartridge/templates/default/account/login.is

ml 

cartridges/int_paypal/cartridge/templates/default/checkout/billing

/paymentOptions/paymentOptionsContent.isml 

cartridges/int_paypal/cartridge/templates/default/checkout/checkou

t.isml 

cartridges/int_paypal/cartridge/templates/default/search/searchRes

ults.isml 

cartridges/int_paypal/cartridge/templates/default/paypal/cart/payp

alCartContent.isml 

cartridges/int_paypal/cartridge/templates/default/paypal/cart/appl

ePayCartContent.isml 
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cartridges/int_paypal/cartridge/templates/default/paypal/pdp/apple

PayPdpContent.isml 

The file with the current version of the PayPal cartridge is located at: 

cartridges/int_paypal/cartridge/templates/resources/paypalVersion.

properties 

The file with the current version of the SFRA cartridge is located at: 

cartridges/app_storefront_base/cartridge/templates/resources/versi

on.properties 

9.2 SFRA Version Support 

PayPal cartridge version 24.2.0 supports SFRA 7.0.0. 

9.3 Compatibility Mode 

Cartridge tested with Compatibility Mode 21.2. 

10 Service Errors Handling 

10.1 Service Timeout Handle 

If a PayPal service becomes unavailable, the error details can be found in the following 

logs: 

• Error details can be found in the log with the custom-PayPal prefix. 

• Service request/response details can be found in the log with the service-PayPalRest 

prefix. 

On the storefront, the customer will see a PayPal button, but the pop-up will close 

instantly. 

For more details about logs, see Logs section. 

For more information about how to track service downtime and about possible options for 

configuration in situations when PayPal API is unavailable or throws an error, review HTTP 

Service Availability section. 

10.2 Fallback/Recovery 

If you continue to see issues where the PayPal button and/or experience is not rendering, 

or if you are seeing 500 or 400 errors in the logs, please contact your PayPal representative 

or create a request to the Merchant Technical Support so that we may investigate this 

further. These orders will not be processable with the PayPal payment option, and you 

may need to temporarily disable PayPal until the issue is resolved.  

Please be aware that when contacting PayPal, we will ask for the details that may need 

to be extracted from the logs as well as for assistance with reproducing the issue step by 

step. 
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10.3 Handle Error Response  

Error handling in the integration is based on the SFRA built-in error logic. If it is possible 

detailed error will be shown to a customer (Figure 10.3.1). In cases where customization 

is not possible, the customer will see SFRA system error (Figure 10.3.2). In this case, a 

detailed error from PayPal can be found at custom-PayPal log. Review Logs section for 

more details. 

All errors text located at 

int_paypal/cartridge/templates/resources/paypalerrors.properties. 

You can add your own text for errors from REST API, using format: paypal.error + error 

code from paypal or error name in lower case. For example: 

paypal.error.transaction_refused=Transaction was refused by 

merchant 

paypal.error.unprocessable_entity=Please check billing address 

UPDATE: Custom errors text will not appear on the order review page due to built-in 

SFRA logic. A System message will always appear (Figure 10.3.2). 

 

 

Figure 10.3.1. Custom error message example 
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Figure 10.3.2. SFRA standard error message example 

11 Automated Testing 
The cartridge has unit tests included in the repository. 

Please use the instructions described in the test/unit/README.md, 

test/integration/README.md, and test/acceptance/README.md files in the 

repository to configure and run tests. 

 

12 Recommendations 
Since it is possible to create a PayPal account via a verified mobile phone but with an 

unverified email address, it is best to unselect the 'Enable customers who have not yet 

confirmed their email with PayPal to log in to your app' checkbox to reduce the 

possibility of security risks. 

To do so, you as a merchant should access your PayPal Sandbox account at 

https://developer.paypal.com/home/, then go to App & Credentials and choose your 

app. Under Sandbox App Settings scroll down to Log in with PayPal & click Advanced 

Settings. In the opened form uncheck 'Enable customers who have not yet confirmed 

their email with PayPal to log in to your app' checkbox. 

 

https://developer.paypal.com/home/
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Figure 12.1.  Unselecting 'Enable customers who have not yet confirmed their email 
with PayPal to log in to your app' checkbox Step 1  Step 2 
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Figure 12.2. Unselecting 'Enable customers who have not yet confirmed their email 
with PayPal to log in to your app' checkbox Step 3 & Step 4 

 

 

Figure 12.3. Unselecting 'Enable customers who have not yet confirmed their email 

with PayPal to log in to your app' checkbox Step 5 
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13 Known Issues 
No reported issues so far. 

14 Upgrade Guide 
Upgrading to 23.3.0 or newer from 23.2.0 or earlier 

14.1 Manual update 

List of custom attributes (should be removed) 

Old attribute ID New attribute ID 

PP_API_PaymentAction PP_Payment_Model 

PP_API_APM_methods PP_Alternative_Payment_Methods 

PP_API_Button_Location PP_Button_Location 

PP_API_BA_Enabled PP_BA_Enabled 

PP_API_BA_Description PP_BA_Description 

PP_Automatic_PM_adding_enabled PP_Automatic_Payment_Method_Adding_Enabled 

PP_API_PAY_NOW_ENABLED PP_Digital_Goods_Flow_Enabled 

PP_FRAUDNET_ENABLED PP_FraudNet_Enabled 

 

List of attribute groups (should be removed) 

Old group ID New group ID 

Paypal_Credit_Messaging PAYPAL_PAY_LATER_BANNERS_MESSAGING 

Paypal_Checkout PAYPAL_CHECKOUT 

Missing PAYPAL_GENERAL 

Missing PAYPAL_CREDIT_CARD 

Missing removed 

  

There are two ways to remove old attributes. 

First approach: 

• Remove old attributes: 

o Go to Business Manager > Administration > Site Development > System Object Types 
> Site Preferences - Attribute Definitions 

o Select a checkbox for the required IDs. 
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o Click on Delete button and you will see a message (Are you sure that you want to 
execute the following action for these items: delete?) 

o Click on Delete button. 

 

• Remove old groups: 

o Go to Business Manager > Administration > Site Development > System Object Types 
> Site Preferences - Attribute Groups 

o Select a checkbox for the required IDs. 

o Click on Delete button and you will see a message (Are you sure that you want to 

execute the following action for these items: delete?) 

o Click on Delete button. 

 

Second approach: 

PLEASE NOTE: When using this approach, you may affect the metadata from the other 

cartridges. We recommend using the first way to remove old attributes. 

• Remove old attributes and groups: 

o Go to Business Manager > Administration > Site Development > Import & Export 

 

Figure 14.1.1. Import & Export 

o Meta data > Click on Export button. 

o Select the checkbox System Object Type Extensions 

o Specify the file name for export (for example: bt-system-object-type-extensions.xml) 

 

Figure 14.1.2. Export System Object Type Extensions 

o Click on Export button. 
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o Wait until the export status is Success.  

 

Figure 14.1.3. Successful export of meta data 

o Download the exported file and delete the old attributes and groups. Be attentive. 

o Upload the modified file for import. Click on Upload button. 

 

o Click on Choose file button and select modified file. Click on Upload button. 
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Figure 14.1.4. Upload import file 

 

o Go to Business Manager > Administration > Site Development > Import & Export 

o Meta data > Click on Export button. 

o Mark file that you want to import and click Next button. 

 

o Mark checkbox in Import Options section and click Import button. 
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o Confirm the action, click OK button. 

o Wait until the Import status is Success. 

 

 

14.2 Migration from Billing Agreement to Vault flow.  

Starting from version 24.2.0 Billing Agreement is deprecated and new Vault flow is 

introduced. In order to migrate, see PayPal Vault Flow. 
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